bem

Affected components
API
Updates

Resolved

Textract issues recover after AWS team’s successful fixes shipped to smooth over the NLB

Mon, Oct 20, 2025, 07:40 PM

Monitoring

Textract timeout issues emerge again due to AWS team’s updates to the AWS Network Load Balancer (NLB)

Mon, Oct 20, 2025, 05:40 PM(2 hours earlier)

Monitoring

Textract issues recover

Mon, Oct 20, 2025, 12:00 PM(5 hours earlier)

Monitoring

  • DNS recovers

  • Textract timeout issues continue, leading to degraded performance on some inputs processed through bem

Mon, Oct 20, 2025, 09:25 AM(2 hours earlier)

Identified

  • DNS outage with app.bem.ai and api.bem.ai unreachable by many clients with inconsistent DNS resolution

  • AWS Textract time out issues begin

Mon, Oct 20, 2025, 08:30 AM(55 minutes earlier)