bem

Increased Latency for Data Transformations
Resolved·Degraded performance

Transformation latency has stabilized. We will continue to monitor performance with the changes deployed today.

Wed, Nov 5, 2025, 01:05 AM
(3 days ago)
·
Affected components
API
Updates

Resolved

Transformation latency has stabilized. We will continue to monitor performance with the changes deployed today.

Wed, Nov 5, 2025, 01:05 AM

Monitoring

We have pushed the longer term fix and latency should be returning to expected levels. We will continue to monitor the situation to ensure stabilization of our vision inference.

Tue, Nov 4, 2025, 11:19 PM(1 hour earlier)

Monitoring

Vision inference latency has stabilized in our internal monitoring over the last hour after our change. We will be shipping the longer-term performance stabilization today and will continue to monitor latency.

Tue, Nov 4, 2025, 10:12 PM(1 hour earlier)

Monitoring

We have deployed a temporary performance fix to our vision inference layer to stabilize latency. We are monitoring latency on that end. Additionally, we are continuing to work on a longer-term performance stabilization.

Tue, Nov 4, 2025, 09:10 PM(1 hour earlier)

Identified

We have identified the root cause as a degradation with our inference provider. We are working with them to reduce latency with bem function calls.

Tue, Nov 4, 2025, 06:59 PM(2 hours earlier)

Investigating

We've had reports and have seen increased spikes in latency in our vision layer. We are investigating the root cause now.

Tue, Nov 4, 2025, 05:57 PM(1 hour earlier)